BackstageItemUtilities Class
Beta
Utilities for creating and maintaining backstage items
Methods
Name | Description | |
---|---|---|
constructor(): BackstageItemUtilities | ||
createActionItem(itemId: string, groupPriority: number, itemPriority: number, execute: () => void, label: string, subtitle?: string, iconSpec?: string, overrides?: Partial<BackstageActionItem>): BackstageActionItem Static | Creates an action backstage item. | |
createStageLauncher(frontstageId: string, groupPriority: number, itemPriority: number, label: string, subtitle?: string, iconSpec?: string, overrides?: Partial<BackstageStageLauncher>): BackstageStageLauncher Static | Creates a stage launcher backstage item. | |
getBackstageItemStateFromProps(props: BackstageItemProps): BackstageItemState Static | Helper method to set backstage item state from props. | Deprecated |
Defined in
Last Updated: 20 June, 2023