BackstageStageLauncher Interface
Beta
Describes the data needed to insert an action button into the backstage menu.
Extends
- BackstageStageLauncher
Properties
Name | Type | Description | |
---|---|---|---|
type Readonly | StageLauncher |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
applicationData | undefined | any | UIA_BackstageStageLauncher | can be used by application to store miscellaneous data. |
badgeType Readonly | undefined | BadgeType | UIA_BackstageStageLauncher | Describes badge. |
groupPriority Readonly | number | UIA_BackstageStageLauncher | Specifies the item's grouping value. |
icon Readonly | string | ConditionalStringValue | UIA_BackstageStageLauncher | Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id. |
id Readonly | string | UIA_BackstageStageLauncher | Required unique id of the item. |
internalData Readonly | undefined | Map<string, any> | UIA_BackstageStageLauncher | optional data to be used by item implementor. |
isActive Readonly | boolean | ConditionalBooleanValue | UIA_BackstageStageLauncher | Describes if the item is active. |
isDisabled Readonly | boolean | ConditionalBooleanValue | UIA_BackstageStageLauncher | Describes if the item is enabled or disabled. |
isHidden Readonly | boolean | ConditionalBooleanValue | UIA_BackstageStageLauncher | Describes if the item is visible or hidden. |
itemPriority Readonly | number | UIA_BackstageStageLauncher | Priority within a group (recommend using values 1 through 100). |
label Readonly | string | ConditionalStringValue | UIA_BackstageStageLauncher | Label. |
providerId Readonly | undefined | string | UIA_BackstageStageLauncher | id of UiItemsProvider |
stageId Readonly | string | UIA_BackstageStageLauncher | |
subtitle Readonly | string | ConditionalStringValue | UIA_BackstageStageLauncher | Subtitle. |
tooltip Readonly | string | ConditionalStringValue | UIA_BackstageStageLauncher | Tooltip. |
Defined in
Last Updated: 20 June, 2023