BackstageActionItem Interface
Beta
Describes the data needed to insert an action button into the backstage menu.
Extends
Inherited methods
Name |
Inherited from |
Description |
execute(): void Readonly |
UIA_BackstageActionItem |
|
Properties
Name |
Type |
Description |
|
type Readonly |
ActionItem |
|
|
Inherited properties
Name |
Type |
Inherited from |
Description |
applicationData |
undefined | any |
UIA_BackstageActionItem |
can be used by application to store miscellaneous data. |
badgeType Readonly |
undefined | BadgeType |
UIA_BackstageActionItem |
Describes badge. |
groupPriority Readonly |
number |
UIA_BackstageActionItem |
Specifies the item's grouping value. |
icon Readonly |
string | ConditionalStringValue |
UIA_BackstageActionItem |
Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id. |
id Readonly |
string |
UIA_BackstageActionItem |
Required unique id of the item. |
internalData Readonly |
undefined | Map<string, any> |
UIA_BackstageActionItem |
optional data to be used by item implementor. |
isActive Readonly |
boolean | ConditionalBooleanValue |
UIA_BackstageActionItem |
Describes if the item is active. |
isDisabled Readonly |
boolean | ConditionalBooleanValue |
UIA_BackstageActionItem |
Describes if the item is enabled or disabled. |
isHidden Readonly |
boolean | ConditionalBooleanValue |
UIA_BackstageActionItem |
Describes if the item is visible or hidden. |
itemPriority Readonly |
number |
UIA_BackstageActionItem |
Priority within a group (recommend using values 1 through 100). |
label Readonly |
string | ConditionalStringValue |
UIA_BackstageActionItem |
Label. |
providerId Readonly |
undefined | string |
UIA_BackstageActionItem |
id of UiItemsProvider |
subtitle Readonly |
string | ConditionalStringValue |
UIA_BackstageActionItem |
Subtitle. |
tooltip Readonly |
string | ConditionalStringValue |
UIA_BackstageActionItem |
Tooltip. |
Defined in
Last Updated:
20 June, 2023