ModalDialogManager Class
Deprecated in 3.7. Use UiFramework.dialogs.modal
property.
Modal Dialog Manager class displays and manages multiple modal dialogs
Methods
Name | Description | |
---|---|---|
constructor(): ModalDialogManager | ||
closeDialog(dialog?: ReactNode): void Static | Close a modal dialog | |
openDialog(dialog: ReactNode, id?: string, parentDocument: Document = document): void Static | Open a modal dialog | |
update(): void Static | Update the dialogs |
Properties
Name | Type | Description | |
---|---|---|---|
activeDialog Accessor StaticReadOnly | ReactNode | Get the active modal dialog | |
dialogCount Accessor StaticReadOnly | number | Get the count of modal dialogs | |
dialogs Accessor StaticReadOnly | DialogInfo[] | Get the array of modal dialogs | |
onModalDialogChangedEvent Accessor StaticReadOnly | ModalDialogChangedEvent | Modal Dialog Changed Event |
Defined in
Last Updated: 20 June, 2023