CursorPopupProps Interface
Properties for the CursorPopup React component
Extends
Methods
Name | Description | |
---|---|---|
onSizeKnown(size: SizeProps): void Optional | Function called when size is known. |
Properties
Name | Type | Description | |
---|---|---|---|
content | ReactNode | ||
id | string | ||
offset | PointProps | ||
pt | PointProps | ||
relativePosition | RelativePosition | ||
shadow | undefined | boolean | ||
title | undefined | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | CommonProps | Custom CSS class name |
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
style | undefined | CSSProperties | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 June, 2023