IModelViewportControlOptions Interface
IModelViewportControl options. These options are set in the applicationData property of the ContentProps.
Methods
Name | Description | |
---|---|---|
supplyViewOverlay(_viewport: ScreenViewport): ReactNode Optional | Optional property to supply custom view overlay. |
Properties
Name | Type | Description | |
---|---|---|---|
alwaysUseSuppliedViewState | undefined | boolean | Optional property to always use the supplied viewState property instead of using viewport.view when set |
|
bgColor | undefined | string | Optional background color which may be used if viewState and iModelConnection are undefined | |
deferNodeInitialization | undefined | boolean | Optional property to defer reactNode initialization until first reactNode property is needed. | |
featureOptions | undefined | { T } | Map of options that can be used to enable/disable features within the view | |
iModelConnection | IModelConnection | () => IModelConnection | IModelConnection of data in Viewport | |
viewState | undefined | ViewStateProp | ViewState or a function to return a ViewState |
Defined in
Last Updated: 20 June, 2023