FrontstageConfig Interface
Beta
Configuration from which a frontstage is created.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
bottomPanel Readonly | undefined | StagePanelConfig | Bottom panel of the application. | |
contentGroup Readonly | ContentGroupProvider | ContentGroup | The Content Group providing the Content Views | |
contentManipulation Readonly | undefined | WidgetConfig | The top-left corner that shows tools typically used to query and modify content. | |
id Readonly | string | Id for the Frontstage | |
leftPanel Readonly | undefined | StagePanelConfig | Left panel of the application. | |
rightPanel Readonly | undefined | StagePanelConfig | Right panel of the application. | |
statusBar Readonly | undefined | WidgetConfig | The status bar of the application. | |
toolSettings Readonly | undefined | WidgetConfig | The settings of the active tool. | |
topPanel Readonly | undefined | StagePanelConfig | Top panel of the application. | |
usage Readonly | undefined | string | Usage type for this Frontstage. | |
version Readonly | number | Frontstage version. | |
viewNavigation Readonly | undefined | WidgetConfig | The top-right corner that shows view navigation tools. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | CommonProps | Custom CSS class name |
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
style | undefined | CSSProperties | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 June, 2023