ContentLayoutManager Class
Deprecated in 3.7. Use UiFramework.content.layouts
property.
ContentLayout Manager class.
Methods
Name | Description | |
---|---|---|
constructor(): ContentLayoutManager | ||
addLayout(layoutId: string, layoutDef: ContentLayoutDef): void Static | Adds a Content Layout. | |
findLayout(layoutKey: string): undefined | ContentLayoutDef Static | Finds a Content Layout with a given id. | |
getLayoutForGroup(contentGroupProps: ContentGroupProps | ContentGroup, overrideContentLayout?: ContentLayoutProps): ContentLayoutDef Static | Return a LayoutDef that is specific to a content group. | |
getLayoutKey(props: { contentGroupId: string, layoutId: string }): string Static | build a layout key that is unique for group layout combination | |
refreshActiveLayout(): void Static | Refreshes the active layout and content group. | |
setActiveContentGroup(contentGroup: ContentGroup): Promise<void> Static | Sets the active Content Group. | |
setActiveLayout(contentLayoutDef: ContentLayoutDef, contentGroup: ContentGroup): Promise<void> Static | Sets the active Content Layout, Content Group and Content Control. |
Properties
Name | Type | Description | |
---|---|---|---|
activeContentGroup Accessor StaticReadOnly | undefined | ContentGroup | Gets the active Content Group | |
activeLayout Accessor StaticReadOnly | undefined | ContentLayoutDef | Gets the active Content Layout |
Defined in
Last Updated: 20 June, 2023