ListPickerBase Class
Beta
Deprecated in 3.5. Used in UI1.0 only.
List picker base class. Used to provide an expandable list of items to enable/disable items.
Extends
- PureComponent<ListPickerProps, ListPickerState>
Methods
Name | Description | |
---|---|---|
constructor(props: any): ListPickerBase | Creates a ListPickerBase | |
getExpandedContent(): ReactNode | Returns the list with the items | |
isExpanded(): boolean | Checks if ExpandableItem is expanded. | |
minimize(): void | Minimizes the expandable component. | |
render(): Element | Renders ListPickerBase |
Defined in
Last Updated: 20 June, 2023