ListPicker Class
Beta
List Picker that lets the user pick from a list of items to enable/disable It also provides options to enable all, disable all and invert selection
Extends
- Component<ListPickerPropsExtended>
Methods
Name | Description | |
---|---|---|
constructor(props: ListPickerPropsExtended): ListPicker | Creates a ListPicker | |
isSpecialItem(item: ListItem): boolean | Checks if item is a special item. | |
render(): Element | Renders ListPicker |
Properties
Name | Type | Description | |
---|---|---|---|
Key_All Accessor StaticReadOnly | number | ||
Key_Invert Accessor StaticReadOnly | number | ||
Key_None Accessor StaticReadOnly | number | ||
Key_Separator Accessor StaticReadOnly | number |
Defined in
Last Updated: 20 June, 2023