ReducerRegistry Class
Beta
Redux Reducer Registry. Follows the example at http://nicolasgallagher.com/redux-modules-and-code-splitting/ Allows for small modules to provide their own reducers so that the they can manage their own state
Methods
Name | Description | |
---|---|---|
constructor(): ReducerRegistry | ReducerRegistry constructor that initializes an empty reducer map to be populated by called to registerReducer. | |
getReducers(): NameToReducerMap | Returns map of registered Reducers. | |
registerReducer(name: string, reducer: (state: any, action: any) => any): void | Call to register a reducer and its name. |
Defined in
Last Updated: 20 June, 2023