DrawingNavigationAidControl Class
Beta
Navigation Aid that displays an interactive mini-map for Drawing views that synchronizes with the iModel Viewport.
Extends
Methods
Name | Description | |
---|---|---|
constructor(info: ConfigurableCreateInfo, options: any): DrawingNavigationAidControl | Creates an instance of ConfigurableUiControl. | |
getSize(): undefined | string | Square size of navigation aid. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
getType(): ConfigurableUiControlType | NavigationAidControl | Get the type of this control. |
onFrontstageDeactivated(): void | NavigationAidControl | Called when Frontstage is deactivated. |
onFrontstageReady(): void | NavigationAidControl | Called when Frontstage is ready. |
onInitialize(): void | NavigationAidControl | Called to initialize the ConfigurableUiControl. |
Properties
Name | Type | Description | |
---|---|---|---|
navigationAidId Static | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_appDataOptions Protected | any | NavigationAidControl | |
applicationData Accessor ReadOnly | any | NavigationAidControl | allow options set via appData to be seen by API calls |
classId Accessor ReadOnly | string | NavigationAidControl | Gets the class Id of configurable element |
controlId Accessor ReadOnly | string | NavigationAidControl | Returns the ID of this ConfigurableUiControl. |
isReady Accessor ReadOnly | Promise<void> | NavigationAidControl | Returns a promise that resolves when the control is ready for usage. |
name Accessor ReadOnly | string | NavigationAidControl | Get internal name of configurable element. If no name is defined in configuration then the name will match the UniqueId. |
reactNode Accessor | ReactNode | NavigationAidControl | The React element associated with this control |
Defined in
Last Updated: 20 June, 2023