CustomItemDef Class
An Item that renders a React component.
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: CustomItemProps): CustomItemDef | ||
toolbarReactNode(index?: number): ReactNode |
Inherited methods
Name | Inherited from | Description |
---|---|---|
execute(): void | ActionButtonItemDef | Called when the action button is invoked by a click or touch |
getDimension(orientation: Orientation): number | ActionButtonItemDef | Determines the dimension in a given orientation |
handleSizeKnown(size: SizeProps): void | ActionButtonItemDef | Called when the size of the action button is initialized and the size is known |
setDescription(v: string | ConditionalStringValue | StringGetter): void | ActionButtonItemDef | Set the description. |
setLabel(v: string | ConditionalStringValue | StringGetter): void | ActionButtonItemDef | Set the label. |
setTooltip(v: string | ConditionalStringValue | StringGetter): void | ActionButtonItemDef | Set the tooltip. |
initializeDef(me: ItemDefBase, itemProps: ItemProps): void Static | ActionButtonItemDef |
Properties
Name | Type | Description | |
---|---|---|---|
customId | string | ||
customIdPrefix Static | string | ||
id Accessor ReadOnly | string | ||
popupPanelNode | undefined | ReactNode | ||
reactElement | undefined | ReactNode |
Inherited properties
Defined in
Last Updated: 20 June, 2023