StandardFrontstageProvider Class
FrontstageProvider that provides an "empty" stage. All tool buttons, statusbar items, and widgets must be provided by one or more item providers, see UiItemsProvider.
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: StandardFrontstageProps): StandardFrontstageProvider |
Inherited methods
Name | Inherited from | Description |
---|---|---|
frontstageConfig(): FrontstageConfig Optional | FrontstageProvider | Return the frontstage configuration. |
Properties
Name | Type | Description | |
---|---|---|---|
frontstage Accessor ReadOnly | ReactElement<FrontstageProps, string | JSXElementConstructor<any>> | ||
id Accessor ReadOnly | string |
Defined in
Last Updated: 20 June, 2023