StandardFrontstageProps Interface
Props for StandardFrontstageProvider
Properties
Name | Type | Description | |
---|---|---|---|
applicationData | undefined | any | Application data is not require but exists for stages to pass feature settings to UiItemsProviders. | |
bottomPanelProps | undefined | WidgetPanelProps | Props used to set initial size and state of panel. | |
contentGroupProps | ContentGroupProps | ContentGroupProvider | Definition of available content groups or a function that provides them | |
cornerButton | undefined | ReactNode | Specify button to use to open backstage. | |
defaultTool | undefined | ToolItemDef | The defaultTool is is started when then frontstage loads and whenever any other tools exit. | |
hideNavigationAid | undefined | boolean | Set to true if default Navigation aid is not desired | |
hideStatusBar | undefined | boolean | Set to true if no status bar is needed in stage | |
hideToolSettings | undefined | boolean | Set to true if no tool setting dock is needed. | |
id | string | ||
leftPanelProps | undefined | WidgetPanelProps | Props used to set initial size and state of panel. | |
rightPanelProps | undefined | WidgetPanelProps | Props used to set initial size and state of panel. | |
topPanelProps | undefined | WidgetPanelProps | Props used to set initial size and state of panel. | |
usage | string | ||
version | undefined | number |
Defined in
Last Updated: 20 June, 2023