ToolItemDef Class
An Item that starts the execution of a Tool.
Extends
Methods
Name | Description | |
---|---|---|
constructor(toolItemProps: ToolItemProps, onItemExecuted?: OnItemExecutedFunc): ToolItemDef | ||
getItemDefForTool(tool: undefined, iconSpec?: string, ...args: any[]): ToolItemDef Static | Create a ToolItemDef that will run a registered tool. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
execute(): void | ActionButtonItemDef | Called when the action button is invoked by a click or touch |
getDimension(orientation: Orientation): number | ActionButtonItemDef | Determines the dimension in a given orientation |
handleSizeKnown(size: SizeProps): void | ActionButtonItemDef | Called when the size of the action button is initialized and the size is known |
setDescription(v: string | ConditionalStringValue | StringGetter): void | ActionButtonItemDef | Set the description. |
setLabel(v: string | ConditionalStringValue | StringGetter): void | ActionButtonItemDef | Set the label. |
setTooltip(v: string | ConditionalStringValue | StringGetter): void | ActionButtonItemDef | Set the tooltip. |
initializeDef(me: ItemDefBase, itemProps: ItemProps): void Static | ActionButtonItemDef |
Properties
Name | Type | Description | |
---|---|---|---|
id Accessor ReadOnly | string | ||
toolId | string |
Inherited properties
Defined in
Last Updated: 20 June, 2023