FrontstageProps Interface
Deprecated in 3.5. Props of a deprecated component.
Properties for a Frontstage component.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
applicationData | undefined | any | Any application data to attach to this Frontstage. | |
bottomCenter | undefined | ReactElement<ZoneProps, string | JSXElementConstructor<any>> | The Zone along the bottom-center edge. | Deprecated |
bottomLeft | undefined | ReactElement<ZoneProps, string | JSXElementConstructor<any>> | The Zone in the bottom-left corner. | Deprecated |
bottomMostPanel | undefined | ReactElement<StagePanelProps, string | JSXElementConstructor<any>> | The StagePanel on the very bottom across the full width. | Deprecated |
bottomPanel | undefined | ReactElement<StagePanelProps, string | JSXElementConstructor<any>> | The StagePanel on the bottom of the AppUi container. | |
bottomRight | undefined | ReactElement<ZoneProps, string | JSXElementConstructor<any>> | The Zone in the bottom-right corner. | Deprecated |
centerLeft | undefined | ReactElement<ZoneProps, string | JSXElementConstructor<any>> | The Zone along the center-left edge. | Deprecated |
centerRight | undefined | ReactElement<ZoneProps, string | JSXElementConstructor<any>> | The Zone along the center-right edge. | Deprecated |
contentGroup | ContentGroupProvider | ContentGroup | The Content Group providing the Content Views | |
contentManipulationTools | undefined | ReactElement<ZoneProps, string | JSXElementConstructor<any>> | The Zone in the top-left corner that shows tools typically used to query and modify content. | |
defaultContentId | undefined | string | Id of the Content View to be activated initially | |
defaultTool | ToolItemDef | Tool that is started once the Frontstage is activated. | |
id | string | Id for the Frontstage | |
isIModelIndependent | undefined | boolean | if isIModelIndependent then frontstage is independent from any iModel. | |
isInFooterMode | undefined | boolean | Indicated whether the StatusBar is in footer mode or widget mode. | Deprecated |
leftPanel | undefined | ReactElement<StagePanelProps, string | JSXElementConstructor<any>> | The StagePanel on the left. | |
rightPanel | undefined | ReactElement<StagePanelProps, string | JSXElementConstructor<any>> | The StagePanel on the right. | |
statusBar | undefined | ReactElement<ZoneProps, string | JSXElementConstructor<any>> | The status bar Zone shown as the application footer. | |
toolSettings | undefined | ReactElement<ZoneProps, string | JSXElementConstructor<any>> | The Zone the that shows settings for the active tool. | |
topCenter | undefined | ReactElement<ZoneProps, string | JSXElementConstructor<any>> | The Zone along the top-center edge. | Deprecated |
topLeft | undefined | ReactElement<ZoneProps, string | JSXElementConstructor<any>> | The Zone in the top-left corner. | Deprecated |
topMostPanel | undefined | ReactElement<StagePanelProps, string | JSXElementConstructor<any>> | The StagePanel on the very top across the full width. | Deprecated |
topPanel | undefined | ReactElement<StagePanelProps, string | JSXElementConstructor<any>> | The StagePanel on the top of the AppUi container. | |
topRight | undefined | ReactElement<ZoneProps, string | JSXElementConstructor<any>> | The Zone in the top-right corner. | Deprecated |
usage | undefined | string | Usage type for this Frontstage. | |
version | undefined | number | Frontstage version. | |
viewNavigationTools | undefined | ReactElement<ZoneProps, string | JSXElementConstructor<any>> | The Zone in the top-right corner that shows view navigation tools. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | CommonProps | Custom CSS class name |
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
style | undefined | CSSProperties | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 June, 2023