ZoneProps Interface
Deprecated in 3.5. Props of a deprecated component.
Properties of a Zone component
Extends
Properties
Name | Type | Description | |
---|---|---|---|
allowsMerging | undefined | boolean | Indicates if other Zones may be merged with this Zone. | |
applicationData | undefined | any | Any application data to attach to this Zone. | |
defaultState | undefined | ZoneState | Default Zone state. | |
initialWidth | undefined | number | Describes preferred initial width of the zone. | |
mergeWithZone | undefined | ZoneLocation | Indicates with which other zone to merge. | |
widgets | undefined | ReactElement<WidgetProps, string | JSXElementConstructor<any>>[] | Properties for the Widgets in this Zone. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | CommonProps | Custom CSS class name |
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
style | undefined | CSSProperties | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 June, 2023