DefaultContentToolsAppData Interface
Defines options that may be set in frontstage app data to control what group priorities to use for each tool button that can be added by this extension. Defining groupIds is optional and only required if use wants to override the default grouping. This application data is statically set in the FrontstageProvider.
example
const applicationData = {
defaultContentTools: {
vertical: {
selectElementGroupPriority: 100,
measureGroupPriority: 200,
selectionGroupPriority: 300,
},
horizontal: {
clearSelectionGroupPriority: 100,
overridesGroupPriority: 200,
},
},
}
Properties
Defined in
Last Updated: 20 June, 2023