ToolAssistanceFieldProps Interface
Properties of ToolAssistanceField component.
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
onOpenWidget(widget: StatusBarFieldId): void Optional | StatusFieldProps | Function called when the widget is opened or closed. |
Properties
Name | Type | Description | |
---|---|---|---|
cursorPromptTimeout | number | Cursor Prompt Timeout period. | |
defaultPromptAtCursor | boolean | Indicates whether to show promptAtCursor by default. | |
fadeOutCursorPrompt | boolean | Fade Out the Cursor Prompt when closed. | |
includePromptAtCursor | boolean | Indicates whether to include promptAtCursor Checkbox. | |
uiStateStorage | undefined | UiStateStorage | Optional parameter for persistent UI settings. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | StatusFieldProps | Custom CSS class name |
isInFooterMode | undefined | boolean | StatusFieldProps | Indicates whether the StatusBar is in footer mode |
itemId | undefined | string | StatusFieldProps | Optional unique identifier for item. |
openWidget | undefined | StatusBarFieldId | StatusFieldProps | Field Id for open widgets |
style | undefined | CSSProperties | StatusFieldProps | Custom CSS style properties |
Defined in
Last Updated: 20 June, 2023