BackstageComposerProps Interface
Props of BackstageComposer component.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
header Readonly | undefined | ReactNode | React node for an optional header item | |
hideSoloStageEntry Readonly | undefined | boolean | If true and only one stage launcher item is found, do not show entry in backstage | |
items Readonly | undefined | BackstageItem[] | List of static backstage items to show. | |
showOverlay Readonly | undefined | boolean | Indicates whether to place an overlay over the frontstage when the backstage is displayed |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | CommonProps | Custom CSS class name |
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
style | undefined | CSSProperties | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 June, 2023