PropsHelper Class
A set of helper methods for various props
Methods
Name | Description | |
---|---|---|
constructor(): PropsHelper | ||
getAbstractPropsForReactIcon(iconSpec: IconSpec, internalData?: Map<string, any>): Partial<AbstractWidgetProps> | Partial<BackstageItem> Static | ||
getIcon(iconSpec: ConditionalStringValue | ReactNode): undefined | Element Static | Get JSX element that defines an icon. | |
getStringFromSpec(spec: string | ConditionalStringValue | StringGetter): string Static | Get the display string. | |
getStringSpec(explicitValue: undefined | string | ConditionalStringValue | StringGetter, stringKey?: string): string | ConditionalStringValue | StringGetter Static | Get spec for returning a string. | |
isShallowEqual(newObj: any, prevObj: any): boolean Static | returns true if the two objects are the same using a shallow compare of each property |
Defined in
Last Updated: 20 June, 2023