ElementTooltip Class
ElementTooltip React component.
Extends
- Component<CommonProps, ElementTooltipState>
Methods
Name | Description | |
---|---|---|
constructor(props: CommonProps): ElementTooltip | ||
componentDidMount(): void | ||
componentWillUnmount(): void | ||
render(): | Element | ||
hideTooltip(): void Static | ||
showTooltip(el: HTMLElement, message: MessageType, pt?: Readonly<WritableXAndY>, options?: ToolTipOptions): void Static |
Properties
Name | Type | Description | |
---|---|---|---|
isTooltipHalted Accessor Static | boolean | ||
isTooltipVisible Accessor StaticReadOnly | boolean | ||
onElementTooltipChangedEvent Accessor StaticReadOnly | ElementTooltipChangedEvent |
Defined in
Last Updated: 20 June, 2023