StagePanelChangeHandler Interface
Deprecated in 3.5. Used in UI1.0 only.
Interface defining callbacks for stage panel changes
Implemented by
Methods
Name | Description | |
---|---|---|
handlePanelInitialize(panelLocation: StagePanelLocation, size: number): void | ||
handlePanelPaneTargetChange(panelLocation: StagePanelLocation, paneIndex: undefined | number): void | ||
handlePanelResize(panelLocation: StagePanelLocation, resizeBy: number): void | ||
handlePanelTargetChange(panelLocation: undefined | StagePanelLocation): void | ||
handleTogglePanelCollapse(panelLocation: StagePanelLocation): void |
Defined in
Last Updated: 20 June, 2023