FooterModeFieldProps Interface
Properties for a FooterModeField component
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
onOpenWidget(widget: StatusBarFieldId): void Optional | StatusFieldProps | Function called when the widget is opened or closed. |
Properties
Name | Type | Description | |
---|---|---|---|
children | undefined | ReactNode | Field content. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | StatusFieldProps | Custom CSS class name |
isInFooterMode | undefined | boolean | StatusFieldProps | Indicates whether the StatusBar is in footer mode |
itemId | undefined | string | StatusFieldProps | Optional unique identifier for item. |
openWidget | undefined | StatusBarFieldId | StatusFieldProps | Field Id for open widgets |
style | undefined | CSSProperties | StatusFieldProps | Custom CSS style properties |
Defined in
Last Updated: 20 June, 2023