KeyboardShortcutManager Class
Deprecated in 3.7. Use UiFramework.keyboardShortcuts
property.
Keyboard Shortcut Manager
Methods
Name | Description | |
---|---|---|
constructor(): KeyboardShortcutManager | ||
closeShortcutsMenu(): void Static | Closes the Keyboard Shortcuts menu | |
displayShortcutsMenu(): void Static | Displays the Keyboard Shortcuts menu at the cursor | |
getShortcut(keyMapKey: string): undefined | KeyboardShortcut Static | Returns a Keyboard Shortcut from the managed lists | |
initialize(): void Static | Initialize the Keyboard Shortcut manager | Deprecated |
loadKeyboardShortcut(shortcutProps: KeyboardShortcutProps): void Static | Loads a Keyboard Shortcut into the managed list | |
loadKeyboardShortcuts(shortcutList: KeyboardShortcutProps[]): void Static | Loads Keyboard Shortcuts into the managed list | |
processKey(keyboardKey: string, isAltKeyPressed: boolean = false, isCtrlKeyPressed: boolean = false, isShiftKeyPressed: boolean = false): boolean Static | Processes a keystroke and invokes a matching Keyboard Shortcut | |
setFocusToHome(): void Static | Sets focus to Home |
Properties
Name | Type | Description | |
---|---|---|---|
cursorX Accessor StaticReadOnly | number | Returns the cursor X position, which is mouseEvent.pageX. | |
cursorY Accessor StaticReadOnly | number | Returns the cursor Y position, which is mouseEvent.pageY. | |
isFocusOnHome Accessor StaticReadOnly | boolean | Determines if focus is set to Home | |
shortcutContainer Accessor StaticReadOnly | KeyboardShortcutContainer | Returns the managed list of Keyboard Shortcuts |
Defined in
Last Updated: 20 June, 2023