NavigationWidgetComposerProps Interface
Properties for the NavigationWidgetComposer React components
Extends
Properties
Name | Type | Description | |
---|---|---|---|
hideNavigationAid | undefined | boolean | If true no navigation aid will be shown. | |
horizontalToolbar | undefined | ReactNode | Optional Horizontal Toolbar | |
navigationAidHost | undefined | ReactNode | Optional Navigation Aid host. | |
verticalToolbar | undefined | ReactNode | Optional Vertical Toolbar |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | CommonProps | Custom CSS class name |
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
style | undefined | CSSProperties | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 June, 2023