WidgetHost Class
A WidgetHost represents a definition that hosts one or most Widgets in a Frontstage.
Extended by
Methods
Name | Description | |
---|---|---|
constructor(): WidgetHost | Constructor for WidgetHost. | |
addWidgetDef(widgetDef: WidgetDef): void | Adds a WidgetDef to the list of Widgets. | |
findWidgetDef(id: string): undefined | WidgetDef | Finds a WidgetDef with a given Id. | |
getSingleWidgetDef(): undefined | WidgetDef | If there is only one Widget in the Panel, gets the single WidgetDef. |
Properties
Name | Type | Description | |
---|---|---|---|
widgetCount Accessor ReadOnly | number | Gets the number of Widgets. | |
widgetDefs Accessor ReadOnly | undefined | Gets the list of Widgets. |
Defined in
Last Updated: 20 June, 2023