UiShowHideManager Class
Deprecated in 3.7. Use UiFramework.visibility
property.
Maintains Ui Show/Hide state. The Ui
includes widgets, panels and the status bar.
Methods
Name | Description | |
---|---|---|
constructor(): UiShowHideManager | ||
handleContentMouseMove(_event?: MouseEvent<HTMLElement, MouseEvent>): void Static | Handler for when the mouse moves over the content area | |
handleFrontstageReady(): void Static | Handler for when a Frontstage is ready | |
handleWidgetMouseEnter(_event?: MouseEvent<HTMLElement, MouseEvent>): void Static | Handler for when the mouse enters a widget | |
showUiAndCancelTimer(): void Static | Shows the Ui and cancels the inactivity timer | |
showUiAndResetTimer(): void Static | Shows the Ui and resets the inactivity timer |
Properties
Name | Type | Description | |
---|---|---|---|
autoHideUi Accessor Static | boolean | Determines whether the auto-hide Ui feature is on. |
|
inactivityTime Accessor Static | number | Determines the amount of inactivity time before the Ui is hidden. | |
isUiVisible Accessor Static | boolean | Determines if the Ui is visible | |
showHideFooter Accessor Static | boolean | Determines whether the status bar is shown and hidden. | |
showHidePanels Accessor Static | boolean | Determines whether the widget panels are shown and hidden. | |
snapWidgetOpacity Accessor Static | boolean | Determines whether the opacity of a toolbar should snap. | |
useProximityOpacity Accessor Static | boolean | Determines whether the proximity of the mouse should alter the opacity of a toolbar. |
Defined in
Last Updated: 20 June, 2023