UiDataProvidedDialogProps Interface
Props for UiDataProvidedDialog component.
Properties
Name | Type | Description | |
---|---|---|---|
height | string | number | Initial height of dialog. | |
id | undefined | string | Id used to specify dialog. | |
isModal | boolean | Indicates if Dialog is Modal | |
maxHeight | string | number | Maximum height that the dialog may be resized to. | |
maxWidth | string | number | Maximum width that the dialog may be resized to. | |
minHeight | string | number | Minimum height that the dialog may be resized to. | |
minWidth | string | number | Minimum width that the dialog may be resized to. | |
movable | undefined | boolean | Indicates whether the user can move dialog with cursor. | |
resizable | undefined | boolean | Indicates whether the user can resize dialog with cursor. | |
title | string | Dialog title | |
uiDataProvider | DialogLayoutDataProvider | Provider that provides and lays out DialogItems | |
width | string | number | Initial width of dialog. |
Defined in
Last Updated: 20 June, 2023