ToolWidgetPropsEx Interface
Deprecated in 3.6. Use ToolWidgetComposer instead
Properties for the ToolWidget React component.
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
onWidgetStateChanged(): void OptionalReadonly | ToolWidgetProps | Handler for widget state changed event |
restoreTransientState(): boolean OptionalReadonly | ToolWidgetProps | Restore transient DOM state. |
saveTransientState(): void OptionalReadonly | ToolWidgetProps | Save transient DOM state (i.e. |
stateFunc(state: Readonly<WidgetState>): WidgetState OptionalReadonly | ToolWidgetProps | Function executed to determine the state of the widget. |
Properties
Name | Type | Description | |
---|---|---|---|
button | undefined | ReactNode | ||
horizontalToolbar | undefined | ReactNode | ||
verticalToolbar | undefined | ReactNode |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
allowedPanelTargets Readonly | undefined | | ToolWidgetProps | Optional prop specifying which Panel sides can be docking targets for this widget. |
appButton | undefined | CommandItemDef | ToolWidgetProps | |
applicationData Readonly | undefined | any | ToolWidgetProps | Application data attached to the Widget. |
badgeType Readonly | undefined | BadgeType | ToolWidgetProps | Badge to be overlaid on the widget tab. |
canPopout Readonly | undefined | boolean | ToolWidgetProps | Indicates if widget can be popped out to a child window. |
classId | string | ConfigurableUiControlConstructor | ToolWidgetProps | Control's class id |
className | undefined | string | ToolWidgetProps | Custom CSS class name |
control | undefined | ConfigurableUiControlConstructor | ToolWidgetProps | A WidgetControl providing information about the Widget. |
defaultFloatingPosition Readonly | undefined | { x: number, y: number } | ToolWidgetProps | Defines that default Top Left position when widget is floated via API calls |
defaultFloatingSize | undefined | { height: number, width: number } | ToolWidgetProps | Optional default size to use when floating a widget. |
defaultState Readonly | undefined | WidgetState | ToolWidgetProps | Default Widget state. |
element | undefined | ReactNode | ToolWidgetProps | A React component for the Widget. |
fillZone Readonly | undefined | boolean | ToolWidgetProps | Indicates whether this Widget should fill the available space in the Zone. |
floatingContainerId Readonly | undefined | string | ToolWidgetProps | If the widget state is changed to floating and the floatingContainerId is defined, the widget will be added to a |
hideWithUiWhenFloating | undefined | boolean | ToolWidgetProps | Optional prop that tells the widget system to fade this widget out with the rest of the UI when it is in floating state |
horizontalDirection | undefined | Direction | ToolWidgetProps | |
horizontalItems | undefined | ItemList | ToolWidgetProps | |
icon Readonly | string | ConditionalStringValue | ToolWidgetProps | Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id. |
iconSpec | undefined | IconSpec | ToolWidgetProps | CSS class name or SvgSprite/SvgPath for icon. |
id Readonly | undefined | string | ToolWidgetProps | Id used to uniquely identify the widget. |
internalData Readonly | undefined | Map<string, any> | ToolWidgetProps | optional data to used by item implementor. |
isFloatingStateSupported Readonly | undefined | boolean | ToolWidgetProps | Indicates if widget can be in floating state, default to true. |
isFloatingStateWindowResizable Readonly | undefined | boolean | ToolWidgetProps | Indicates if floating widget is resizable, defaults to false which caused the widget to be auto-sized.. |
isFreeform Readonly | undefined | boolean | ToolWidgetProps | Indicates whether the Widget is free-form or rectangular. |
isStatusBar Readonly | undefined | boolean | ToolWidgetProps | Indicates whether this Widget is for the Status Bar. |
isToolSettings Readonly | undefined | boolean | ToolWidgetProps | Indicates whether this Widget is for the Tool Settings. |
itemId | undefined | string | ToolWidgetProps | Optional unique identifier for item. |
label Readonly | string | ConditionalStringValue | ToolWidgetProps | if set, component will be considered selected but will NOT display an "active stripe" - defaults to false. |
labelKey | undefined | string | ToolWidgetProps | if set, it is used to define a key that is used to look up a localized string. |
preferredPanelSize | undefined | "fit-content" | ToolWidgetProps | |
priority Readonly | undefined | number | ToolWidgetProps | Widget priority |
providerId Readonly | undefined | string | ToolWidgetProps | id of UiItemsProvider |
style | undefined | CSSProperties | ToolWidgetProps | Custom CSS style properties |
syncEventIds Readonly | undefined | string[] | ToolWidgetProps | Defines the SyncUi event Ids that will trigger the stateFunc to run to determine the state of the widget. |
tooltip Readonly | string | ConditionalStringValue | ToolWidgetProps | used to explicitly set the tooltip shown by a component. |
tooltipKey | undefined | string | ToolWidgetProps | if set, it is used to define a key that is used to look up a localized string. |
verticalDirection | undefined | Direction | ToolWidgetProps | |
verticalItems | undefined | ItemList | ToolWidgetProps |
Defined in
Last Updated: 20 June, 2023