StatusBarItem Interface
Deprecated in 3.6. Use StatusBarCustomItem instead.
Describes the data needed to insert an item into the StatusBar.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
reactNode Readonly | ReactNode | React node for the StatusBar item. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
applicationData | undefined | any | AbstractStatusBarCustomItem | can be used by application to store miscellaneous data. |
badgeType Readonly | undefined | BadgeType | AbstractStatusBarCustomItem | Describes badge. |
id Readonly | string | AbstractStatusBarCustomItem | Required unique id of the item. |
internalData Readonly | undefined | Map<string, any> | AbstractStatusBarCustomItem | optional data to used by item implementor. |
isCustom Readonly | "true" | AbstractStatusBarCustomItem | |
isDisabled Readonly | boolean | ConditionalBooleanValue | AbstractStatusBarCustomItem | Describes if the item is enabled or disabled. |
isHidden Readonly | boolean | ConditionalBooleanValue | AbstractStatusBarCustomItem | Describes if the item is visible or hidden. |
itemPriority Readonly | number | AbstractStatusBarCustomItem | Priority within a section (recommend using values 1 through 100). |
providerId Readonly | undefined | string | AbstractStatusBarCustomItem | id of UiItemsProvider |
section Readonly | StatusBarSection | AbstractStatusBarCustomItem | status bar section |
Defined in
Last Updated: 20 June, 2023