FrameworkStackedDialog<DialogInfoType> Interface
Beta
FrameworkDialog that manages the top most content.
Extends
Methods
Name | Description | |
---|---|---|
getInfo(id: string): undefined | DialogInfoType | ||
getZIndex(id: string): number | Get the z-index for a modeless dialog | |
handlePointerDownEvent(_event: PointerEvent<Element>, id: string, updateFunc: () => void): void | Handle a pointer down event on a modeless dialog |
Inherited methods
Name | Inherited from | Description |
---|---|---|
close(dialog?: ReactNode): void | FrameworkDialog | Close a modal dialog |
open(dialog: ReactNode, id?: string, parentDocument?: Document): void | FrameworkDialog | Open a modal dialog |
update(): void | FrameworkDialog | Update the dialogs |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
active Readonly | ReactNode | FrameworkDialog | Get the active modal dialog |
count Readonly | number | FrameworkDialog | Get the count of modal dialogs |
dialogs Readonly | DialogInfo[] | FrameworkDialog | Get the array of modal dialogs |
Defined in
Last Updated: 20 June, 2023