ContentViewManager Class
Deprecated in 3.7. Use UiFramework.content
property
Content View Manager class.
Methods
Name | Description | |
---|---|---|
constructor(): ContentViewManager | ||
addFloatingContentControl(contentControl?: ContentControl): void Static | ||
contentSupportsCamera(content: undefined | ContentControl): boolean Static | Determines if viewport supports use of a camera. | |
dropFloatingContentControl(contentControl?: ContentControl): void Static | ||
getActiveContent(): ReactNode Static | Gets the active content as a React.ReactNode. | |
getActiveContentControl(): undefined | ContentControl Static | Return the active ContentControl. | |
isContent3dView(content: undefined | ContentControl): boolean Static | Determines if content displays a 3d view. | |
isContentDrawingView(content: undefined | ContentControl): boolean Static | Determines if content displays a Drawing view. | |
isContentOrthographicView(content: undefined | ContentControl): boolean Static | Determines if content displays a Orthographic view. | |
isContentSheetView(content: undefined | ContentControl): boolean Static | Determines if content displays a Sheet view. | |
isContentSpatialView(content: undefined | ContentControl): boolean Static | Determines if content displays a Spatial view. | |
refreshActiveContent(activeContent: ReactNode): void Static | Refreshes the active ContentControl | |
setActiveContent(activeContent?: ReactNode, forceEventProcessing: boolean = false): void Static | Sets the active ContentControl | |
setMouseDown(mouseDown: boolean): void Static | Sets the mouse down status for a content view |
Properties
Name | Type | Description | |
---|---|---|---|
isMouseDown Accessor StaticReadOnly | boolean | Determines if the mouse is down in a content view | |
onActiveContentChangedEvent Accessor StaticReadOnly | ActiveContentChangedEvent | Gets the ActiveContentChangedEvent | |
onAvailableContentChangedEvent Accessor StaticReadOnly | UiEvent<{ contentId: string }> | Fires when floating contents are added or removed | |
onMouseDownChangedEvent Accessor StaticReadOnly | MouseDownChangedEvent |
Defined in
Last Updated: 20 June, 2023