ViewStateHelperProps Interface
SavedViewProps interface for sharing ViewState and EmphasizeElements information.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
bisBaseClass | string | ||
emphasizeElementsProps | undefined | EmphasizeElementsProps |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
categorySelectorProps | CategorySelectorProps | ViewStateProps | |
displayStyleProps | DisplayStyleProps | ViewStateProps | |
modelExtents | undefined | Range3dProps | ViewStateProps | For a DrawingViewState, the extents of the DrawingModel, used for determining the upper limits of the view's extents. |
modelSelectorProps | undefined | ModelSelectorProps | ViewStateProps | |
sectionDrawing | undefined | SectionDrawingViewProps | ViewStateProps | Information about the SectionDrawing relevant to displaying a drawing view. |
sheetAttachments | undefined | Id64Array | ViewStateProps | The Ids of the ViewAttachments contained within the SheetModel, if this is a sheet view. |
sheetProps | undefined | SheetProps | ViewStateProps | Sheet-specific properties, if this is a view of a SheetModel. |
viewDefinitionProps | ViewDefinitionProps | ViewStateProps |
Defined in
Last Updated: 20 June, 2023