NavigationWidgetPropsEx Interface
Deprecated in 2.x. Use NavigationWidgetComposer instead
Properties for the NavigationWidget React component.
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
onWidgetStateChanged(): void OptionalReadonly | NavigationWidgetProps | Handler for widget state changed event |
restoreTransientState(): boolean OptionalReadonly | NavigationWidgetProps | Restore transient DOM state. |
saveTransientState(): void OptionalReadonly | NavigationWidgetProps | Save transient DOM state (i.e. |
stateFunc(state: Readonly<WidgetState>): WidgetState OptionalReadonly | NavigationWidgetProps | Function executed to determine the state of the widget. |
Properties
Name | Type | Description | |
---|---|---|---|
horizontalToolbar | undefined | ReactNode | ||
iModelConnection | undefined | IModelConnection | ||
verticalToolbar | undefined | ReactNode |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
allowedPanelTargets Readonly | undefined | | NavigationWidgetProps | Optional prop specifying which Panel sides can be docking targets for this widget. |
applicationData Readonly | undefined | any | NavigationWidgetProps | Application data attached to the Widget. |
badgeType Readonly | undefined | BadgeType | NavigationWidgetProps | Badge to be overlaid on the widget tab. |
canPopout Readonly | undefined | boolean | NavigationWidgetProps | Indicates if widget can be popped out to a child window. |
classId | string | ConfigurableUiControlConstructor | NavigationWidgetProps | Control's class id |
className | undefined | string | NavigationWidgetProps | Custom CSS class name |
control | undefined | ConfigurableUiControlConstructor | NavigationWidgetProps | A WidgetControl providing information about the Widget. |
defaultFloatingPosition Readonly | undefined | { x: number, y: number } | NavigationWidgetProps | Defines that default Top Left position when widget is floated via API calls |
defaultFloatingSize | undefined | { height: number, width: number } | NavigationWidgetProps | Optional default size to use when floating a widget. |
defaultState Readonly | undefined | WidgetState | NavigationWidgetProps | Default Widget state. |
element | undefined | ReactNode | NavigationWidgetProps | A React component for the Widget. |
fillZone Readonly | undefined | boolean | NavigationWidgetProps | Indicates whether this Widget should fill the available space in the Zone. |
floatingContainerId Readonly | undefined | string | NavigationWidgetProps | If the widget state is changed to floating and the floatingContainerId is defined, the widget will be added to a |
hideWithUiWhenFloating | undefined | boolean | NavigationWidgetProps | Optional prop that tells the widget system to fade this widget out with the rest of the UI when it is in floating state |
horizontalDirection | undefined | Direction | NavigationWidgetProps | |
horizontalItems | undefined | ItemList | NavigationWidgetProps | |
icon Readonly | string | ConditionalStringValue | NavigationWidgetProps | Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id. |
iconSpec | undefined | IconSpec | NavigationWidgetProps | CSS class name or SvgSprite/SvgPath for icon. |
id Readonly | undefined | string | NavigationWidgetProps | Id used to uniquely identify the widget. |
internalData Readonly | undefined | Map<string, any> | NavigationWidgetProps | optional data to used by item implementor. |
isFloatingStateSupported Readonly | undefined | boolean | NavigationWidgetProps | Indicates if widget can be in floating state, default to true. |
isFloatingStateWindowResizable Readonly | undefined | boolean | NavigationWidgetProps | Indicates if floating widget is resizable, defaults to false which caused the widget to be auto-sized.. |
isFreeform Readonly | undefined | boolean | NavigationWidgetProps | Indicates whether the Widget is free-form or rectangular. |
isStatusBar Readonly | undefined | boolean | NavigationWidgetProps | Indicates whether this Widget is for the Status Bar. |
isToolSettings Readonly | undefined | boolean | NavigationWidgetProps | Indicates whether this Widget is for the Tool Settings. |
itemId | undefined | string | NavigationWidgetProps | Optional unique identifier for item. |
label Readonly | string | ConditionalStringValue | NavigationWidgetProps | if set, component will be considered selected but will NOT display an "active stripe" - defaults to false. |
labelKey | undefined | string | NavigationWidgetProps | if set, it is used to define a key that is used to look up a localized string. |
navigationAidId | undefined | string | NavigationWidgetProps | |
preferredPanelSize | undefined | "fit-content" | NavigationWidgetProps | |
priority Readonly | undefined | number | NavigationWidgetProps | Widget priority |
providerId Readonly | undefined | string | NavigationWidgetProps | id of UiItemsProvider |
style | undefined | CSSProperties | NavigationWidgetProps | Custom CSS style properties |
syncEventIds Readonly | undefined | string[] | NavigationWidgetProps | Defines the SyncUi event Ids that will trigger the stateFunc to run to determine the state of the widget. |
tooltip Readonly | string | ConditionalStringValue | NavigationWidgetProps | used to explicitly set the tooltip shown by a component. |
tooltipKey | undefined | string | NavigationWidgetProps | if set, it is used to define a key that is used to look up a localized string. |
verticalDirection | undefined | Direction | NavigationWidgetProps | |
verticalItems | undefined | ItemList | NavigationWidgetProps |
Defined in
Last Updated: 20 June, 2023