ToolButtonProps Interface
Deprecated in 3.5. Props of a deprecated component.
Properties for the ToolButton React Component.
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
execute(args?: any): any Optional | ToolItemProps | Function to execute |
getCommandArgs(): any[] Optional | ToolItemProps | Function to get the parameters passed to the function |
stateFunc(state: Readonly<BaseItemState>): BaseItemState Optional | ToolItemProps | Function called to get the new items state |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
applicationData | undefined | any | ToolItemProps | can be used by application to store miscellaneous data. |
badgeType | undefined | BadgeType | ToolItemProps | Badge to be overlaid on the item. |
className | undefined | string | ToolItemProps | Custom CSS class name |
description | string | ConditionalStringValue | StringGetter | ToolItemProps | if set, it is used to explicitly set the description shown by a component. |
descriptionKey | undefined | string | ToolItemProps | if set, it is used to define a key that is used to look up a localized string. |
icon | string | ConditionalStringValue | ToolItemProps | abstract icon definition, used when create itemDef from abstract item (ie. |
iconSpec | undefined | IconSpec | ToolItemProps | CSS class name or SvgSprite/SvgPath for icon. |
isActive | undefined | boolean | ToolItemProps | if set, component will be considered "active" an will display an "active stripe" - defaults to false |
isDisabled | boolean | ConditionalBooleanValue | ToolItemProps | if true component will be disabled - defaults to false |
isEnabled | undefined | boolean | ToolItemProps | if set, component will be enabled - defaults to true |
isHidden | boolean | ConditionalBooleanValue | ToolItemProps | if true component will be hidden - defaults to false |
isPressed | undefined | boolean | ToolItemProps | if set, component will be considered selected but will NOT display an "active stripe" - defaults to false. |
isVisible | undefined | boolean | ToolItemProps | if set, component will be visible - defaults to true |
itemId | undefined | string | ToolItemProps | Optional unique identifier for item. |
label | string | ConditionalStringValue | StringGetter | ToolItemProps | if set, it is used to explicitly set the label shown by a component. |
labelKey | undefined | string | ToolItemProps | if set, it is used to define a key that is used to look up a localized string. |
parameters | undefined | any | ToolItemProps | Parameters passed to the function |
stateSyncIds | undefined | string[] | ToolItemProps | Synchronize Ids to listen for |
style | undefined | CSSProperties | ToolItemProps | Custom CSS style properties |
toolId | string | ToolItemProps | |
tooltip | string | ConditionalStringValue | StringGetter | ToolItemProps | used to explicitly set the tooltip shown by a component. |
tooltipKey | undefined | string | ToolItemProps | if set, it is used to define a key that is used to look up a localized string. |
Defined in
Last Updated: 20 June, 2023