AppNotificationManager Class
The AppNotificationManager class is a subclass of NotificationManager in @itwin/core-frontend. This implementation uses the iTwin.js UI library to display alerts, messages, prompts and tooltips.
Extends
Methods
Name | Description | |
---|---|---|
constructor(): AppNotificationManager | ||
_showToolTip(el: HTMLElement, message: string | HTMLElement, pt?: Readonly<WritableXAndY>, options?: ToolTipOptions): void Protected | Show a ToolTip window. | |
clearToolTip(): void | Clear the ToolTip if it is currently open. | |
Hide a InputField message. | ||
Hides the Pointer message. | ||
End an activity message. | ||
Output a MessageBox and wait for response from the user. | ||
Output an activity message to the user. | ||
Output a message and/or alert to the user. | ||
outputPrompt(prompt: string): void | Output a prompt to the user. | |
outputPromptByKey(key: string): void | Output a prompt, given an i18n key. | |
setToolAssistance(instructions: undefined | ToolAssistanceInstructions): void | Setup tool assistance instructions for a tool. | |
Set up for activity messages. | ||
Update message position created with Pointer. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
NotificationManager | Displays an input field notification message. | |
NotificationManager | Displays a notification message. | |
openToolTip(htmlElement: HTMLElement, message: string | HTMLElement, location?: Readonly<WritableXAndY>, options?: ToolTipOptions): void | NotificationManager | Show a tooltip window. |
Properties
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
toolTipLocation Readonly | Point2d | NotificationManager |
Defined in
Last Updated: 20 June, 2023