ActivityMessageDetails Class
Specifies the details of an activity message to be displayed to the user.
extensions
Methods
Name | Description | |
---|---|---|
constructor(showProgressBar: boolean, showPercentInMessage: boolean, supportsCancellation: boolean, showDialogInitially: boolean = true): ActivityMessageDetails | ||
onActivityCancelled(): void | Called from NotificationAdmin when the user cancels the activity. | |
onActivityCompleted(): void | Called from NotificationAdmin when the activity completes successfully. |
Properties
Name | Type | Description | |
---|---|---|---|
showDialogInitially | boolean | ||
boolean | |||
showProgressBar | boolean | ||
supportsCancellation | boolean | ||
wasCancelled | boolean |
Defined in
Last Updated: 20 June, 2023