openToolTip Method
Show a tooltip window. Saves tooltip location for AccuSnap to test if cursor has moved far enough away to close tooltip.
openToolTip(htmlElement: HTMLElement, message: string | HTMLElement, location?: Readonly<WritableXAndY>, options?: ToolTipOptions): void
note If message is an HTMLElement, the notification manager will display the HTMLElement verbatim. This can represent a security risk if any part the element is created from user input. Applications should be careful to sanitize any such input before creating an HTMLElement to pass to this method.
Parameter | Type | Description |
---|---|---|
htmlElement | HTMLElement | The HTMLElement that anchors the toolTip. |
string | HTMLElement | What to display inside the ToolTip. May be a string or an HTMLElement. | |
location | Readonly<WritableXAndY> | An optional location, relative to the origin of _htmlElement, for the ToolTip. If undefined, center of htmlElement |
options | ToolTipOptions | Options that supply additional information about how the ToolTip should function. |
Returns - void
Defined in
Last Updated: 20 June, 2023