combineReducers Function
Turns an object whose values are different reducer functions, into a single reducer function. It will call every child reducer, and gather their results into a single state object, whose keys correspond to the keys of the passed reducer functions.
//@template S Combined state object type.
combineReducers<A>(reducers: A): (state: CombinedReducerState<A>, action: ReducerActions<>) => CombinedReducerState<A>
Returns - (state: CombinedReducerState<A>, action: ReducerActions<>) => CombinedReducerState<A>
Defined in
Last Updated: 20 June, 2023