ConfigurableUiManager Class
Deprecated in 3.7. Use UiFramework.controls
property.
Configurable Ui Manager maintains controls, Frontstages, Content Groups, Content Layouts, Tasks and Workflows.
Methods
Name | Description | |
---|---|---|
constructor(): ConfigurableUiManager | ||
addFrontstageProvider(frontstageProvider: FrontstageProvider): void Static | Add a Frontstage via a provider into the FrontstageManager. | Deprecated |
closeUi(): void Static | Closes all UI popups currently open | |
createControl(classId: string, uniqueId: string, options?: any, controlId?: string): undefined | ConfigurableUiElement Static | Creates a control registered by calling registerControl. | Deprecated |
getWrapperElement(): HTMLElement Static | Gets the HTML wrapper element for Configurable UI | |
initialize(): void Static | Initializes the InternalConfigurableUiManager and registers core controls. | Deprecated |
isControlRegistered(classId: string): boolean Static | Determines if a control has been registered based on its classId. | |
loadKeyboardShortcuts(shortcutList: KeyboardShortcutProps[]): void Static | Loads one or more Keyboard Shortcuts into the KeyboardShortcutManager. | Deprecated |
registerControl(classId: string, constructor: ConfigurableUiControlConstructor): void Static | Registers a control implementing the ConfigurableUiElement interface. | Deprecated |
unregisterControl(classId: string): void Static | Unregisters a control that has been registered. | Deprecated |
Defined in
Last Updated: 20 June, 2023