GroupButtonProps Interface
Deprecated in 3.5. Props of a deprecated component.
Properties for the GroupButton React component
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
stateFunc(state: Readonly<BaseItemState>): BaseItemState Optional | GroupItemProps | Function called to get the new items state |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
applicationData | undefined | any | GroupItemProps | can be used by application to store miscellaneous data. |
badgeType | undefined | BadgeType | GroupItemProps | Badge to be overlaid on the item. |
className | undefined | string | GroupItemProps | Custom CSS class name |
defaultActiveItemId | undefined | string | GroupItemProps | |
description | string | ConditionalStringValue | StringGetter | GroupItemProps | if set, it is used to explicitly set the description shown by a component. |
descriptionKey | undefined | string | GroupItemProps | if set, it is used to define a key that is used to look up a localized string. |
direction | undefined | Direction | GroupItemProps | |
groupId | undefined | string | GroupItemProps | |
icon | string | ConditionalStringValue | GroupItemProps | abstract icon definition, used when create itemDef from abstract item (ie. |
iconSpec | undefined | IconSpec | GroupItemProps | CSS class name or SvgSprite/SvgPath for icon. |
isActive | undefined | boolean | GroupItemProps | if set, component will be considered "active" an will display an "active stripe" - defaults to false |
isDisabled | boolean | ConditionalBooleanValue | GroupItemProps | if true component will be disabled - defaults to false |
isEnabled | undefined | boolean | GroupItemProps | if set, component will be enabled - defaults to true |
isHidden | boolean | ConditionalBooleanValue | GroupItemProps | if true component will be hidden - defaults to false |
isPressed | undefined | boolean | GroupItemProps | if set, component will be considered selected but will NOT display an "active stripe" - defaults to false. |
isVisible | undefined | boolean | GroupItemProps | if set, component will be visible - defaults to true |
itemId | undefined | string | GroupItemProps | Optional unique identifier for item. |
items | AnyItemDef[] | GroupItemProps | |
itemsInColumn | undefined | number | GroupItemProps | |
label | string | ConditionalStringValue | StringGetter | GroupItemProps | if set, it is used to explicitly set the label shown by a component. |
labelKey | undefined | string | GroupItemProps | if set, it is used to define a key that is used to look up a localized string. |
panelLabel | string | StringGetter | GroupItemProps | if set, it is used to explicitly set a label at top of open group component. |
panelLabelKey | undefined | string | GroupItemProps | if set, it is used to define a key that is used to look up a localized string. |
stateSyncIds | undefined | string[] | GroupItemProps | Synchronize Ids to listen for |
style | undefined | CSSProperties | GroupItemProps | Custom CSS style properties |
tooltip | string | ConditionalStringValue | StringGetter | GroupItemProps | used to explicitly set the tooltip shown by a component. |
tooltipKey | undefined | string | GroupItemProps | if set, it is used to define a key that is used to look up a localized string. |
Defined in
Last Updated: 20 June, 2023