core-react
Classes
Name | Description | |
---|---|---|
ActivateSettingsTabEvent | Event class for this.onActivateSettingsTab which is emitted when API call needs to set the active settings tab (ie via Tool key-in). | Deprecated |
AutoSuggest | Auto Suggest React component. | Deprecated |
CheckListBox | React component showing a list of Checkbox items. | Deprecated |
CheckListBoxItem | Item with a checkbox added to a CheckListBox. | Deprecated |
ConditionalIconItem | Class used to return an icon. | Deprecated |
ContextMenu | A context menu populated with ContextMenuItem components. | Deprecated |
ContextMenuDivider | Menu Divider for ContextMenu. | Deprecated |
ContextMenuItem | Menu item component for use within a ContextMenu component. | Deprecated |
ContextSubMenu | Submenu wrapper class for use within a ContextMenu component. | Deprecated |
Dialog | Dialog React component with optional resizing and dragging functionality | Deprecated |
ExpandableList | ExpandableList React component is a container for ExpandableBlock components. | Deprecated |
GlobalContextMenu | GlobalContextMenu React component used to display a ContextMenu at the cursor | Deprecated |
GlobalDialog | GlobalDialog React component used to display a Dialog on the top of screen | Deprecated |
IconHelper | Icon Helper Class used to store the data needed to generate an |
Deprecated |
ImageCheckBox | ImageCheckBox React component shows a checked or unchecked image | Deprecated |
InputLabel | Text input wrapper that provides additional styling and labeling | Deprecated |
LoadingBar | A loading bar with optional percentage text. | Deprecated |
LoadingPrompt | A component to display during loading that optionally shows percentage, status text and a cancel button. | Deprecated |
LoadingSpinner | A loading spinner component that optionally shows a text message. | Deprecated |
LoadingStatus | A loading indicator that shows status text along with the percentage. | Deprecated |
LocalStateStorage | Implementation of UiStateStorage using Window.localStorage. | Deprecated |
Message Box React component. | Deprecated | |
Message Container React component. | Deprecated | |
Popup | Popup React component displays a popup relative to an optional target element. | Deprecated |
ProcessSettingsContainerCloseEvent | Event class for this.onProcessSettingsContainerClose which is emitted when the settings container will be closed. | Deprecated |
ProcessSettingsTabActivationEvent | Event class for this.onProcessSettingsTabActivation which is emitted when a new Tab needs to be activated. | Deprecated |
RadialButton | Button for use within a RadialMenu | Deprecated |
RadialMenu | A context menu arranged in a radial layout. | Deprecated |
ScrollPositionMaintainer | A helper class to recursively save and restore scroll positions. | Deprecated |
SearchBox | Input box for entering text to search for. | Deprecated |
SettingsManager | Settings Manager class. | Deprecated |
SettingsProvidersChangedEvent | Event class for this.onSettingsProvidersChanged which is emitted when a new SettingsTabsProvider is added or removed. | Deprecated |
SvgPath | Svg element wrapper with specified Svg paths. | Deprecated |
Tabs | Tabs meant to represent the current position in a page/section | Deprecated |
Timer | Notifies handler after a set interval. | Deprecated |
Tree | Presentation React component for a Tree | Deprecated |
TreeBranch | Presentation React component for a Tree branch | Deprecated |
TreeNode | Presentation React component for a Tree node | Deprecated |
TreeNodePlaceholder | Presentation React component for a placeholder to be displayed instead of a node while it's being loaded | Deprecated |
UiCore | Manages the Localization service for the core-react package. | Deprecated |
UiStateEntry | A single UI State entry that is identified by namespace and setting name. |
Constants
Name | Description | |
---|---|---|
BadgeType | Specifies type of badge, if any, that should be overlaid on UI component. | Deprecated |
DivWithOutsideClick | Div element with Outside Click behavior | Deprecated |
ListboxContext | Context set up by listbox for use by ListboxItems . |
Deprecated |
Enumerations
Name | Description | |
---|---|---|
CheckBoxState | State of a checkbox | Deprecated |
ContextMenuDirection | Enum to specify where a ContextMenu should anchor to its parent element | Deprecated |
DialogAlignment | Enum for dialog alignment | Deprecated |
HorizontalAlignment | Enumeration for horizontal alignment. | Deprecated |
InputStatus | Enum for Input status | Deprecated |
Orientation | Enumeration of orientation. | Deprecated |
SortDirection | Enumeration for sorting direction. | Deprecated |
TimeFormat | Enumeration of time formats. | Deprecated |
UiStateStorageStatus | Enum for UiStateStorage status. | Deprecated |
VerticalAlignment | Enumeration for vertical alignment. | Deprecated |
Global Functions
Name | Description | |
---|---|---|
BlockText | Styled block text React functional component | Deprecated |
BodyText | Styled body text React functional component | Deprecated |
Centered | Centered React functional component. | Deprecated |
CheckListBoxSeparator | Separator added to a CheckListBox. | Deprecated |
DisabledText | Styled disabled text React functional component | Deprecated |
Div | Base div element React component | Deprecated |
ElementResizeObserver | ElementResizeObserver provides functionality similar to ReactResizeDetector when a render function is specified. | Deprecated |
ElementSeparator | A movable button, which allows to change the ratio between left element and right element | Deprecated |
ExpansionToggle | ExpansionToggle React component used by the TreeNode component to show collapsed or expanded state | Deprecated |
FillCentered | Full height & width and centered React functional component. | Deprecated |
FlexWrapContainer | Flex Wrap Container React functional component. | Deprecated |
Gap | Horizontal gap or space React component. | Deprecated |
getCssVariable | Get CSS variable | Deprecated |
getCssVariableAsNumber | Get CSS variable as number | Deprecated |
Icon | Icon Functional component displays an icon based on an IconSpec. | Deprecated |
IconInput | Input component with icon to the left of the input field | Deprecated |
Listbox | Single select Listbox component |
Deprecated |
ListboxItem | ListboxItem component. |
Deprecated |
React component renders a string, HTMLElement or React node in a div or span |
Deprecated | |
MutedText | Styled muted/gray text React functional component | Deprecated |
NumberInput | Input component for numbers with up and down buttons to increment and decrement the value. | Deprecated |
PopupContextMenu | Component that displays a ContextMenu within a Popup component, allowing the target element to be specified. | Deprecated |
ResizableContainerObserver | ResizableContainerObserver is a component that provides the functionality similar to the ReactResizeDetector option that call a function when | Deprecated |
ScrollView | Scroll View React functional component. | Deprecated |
SettingsContainer | Component that displays setting tabs on the left and the setting page on the right. | Deprecated |
StyledText | The base component for other text components that pass a main CSS class name. | Deprecated |
UnderlinedButton | A React component that makes text clickable and underlined | Deprecated |
useCrossOriginPopup | Hook that will show a popup window | Deprecated |
useDisposable | A custom hook which creates a disposable object and manages its disposal on unmount | Deprecated |
useEffectSkipFirst | Custom hook which works like useEffect hook, but does not invoke callback when effect is triggered for the first time. | Deprecated |
useInterval | Hook that create an interval and clears it when unloaded | Deprecated |
useOnOutsideClick | Invokes onOutsideClick handler when user clicks outside of referenced element. | Deprecated |
useOptionalDisposable | A custom hook which calls the factory method to create a disposable object | Deprecated |
useSaveBeforeActivatingNewSettingsTab | Hook to use within Settings Page component to allow saving the current page's data before loading to the requested Setting Tab's page. | Deprecated |
useSaveBeforeClosingSettingsContainer | Hook to use within Settings Page component to allow saving the current page's data before the Setting Container is closed. | Deprecated |
VerticalTabs | Vertical tabs meant to represent the current position in a page/section | Deprecated |
WebFontIcon | WebFontIcon React component | Deprecated |
withIsPressed | withIsPressed is a React higher-order component that adds pointer and mouse events. | Deprecated |
withOnOutsideClick | withOnOutsideClick is a React higher-order component that adds outside click support. | Deprecated |
withTimeout | withTimeout is a React higher-order component that adds timeout support. | Deprecated |
Interfaces
Name | Description | |
---|---|---|
ActivateSettingsTabEventArgs | Arguments of this.onActivateSettingsTab event. | Deprecated |
AutoSuggestData | Data for the AutoSuggest options | Deprecated |
AutoSuggestProps | Properties for the AutoSuggest component. | Deprecated |
CheckBoxInfo | A data type that holds all the checkbox display attributes | Deprecated |
CheckListBoxItemProps | Properties for the CheckListBoxItem component | Deprecated |
ClassNameProps | Props used by components that expect class name to be passed in. | Deprecated |
CommonDivProps | Common properties using a div element. | Deprecated |
CommonProps | Common props used by components. | Deprecated |
ContextMenuItemProps | Properties for the ContextMenuItem component | Deprecated |
ContextMenuProps | Properties for the ContextMenu component | Deprecated |
ContextSubMenuProps | Properties for the ContextSubMenu component | Deprecated |
DialogProps | Properties for the Dialog component | Deprecated |
DivProps | Properties for the Div component | Deprecated |
ElementSeparatorProps | Properties of ElementSeparator React component | Deprecated |
ExpandableListProps | Properties for ExpandableList component | Deprecated |
ExpansionToggleProps | Properties for the ExpansionToggle component | Deprecated |
GapProps | Properties for the Gap component. | Deprecated |
GlobalContextMenuProps | Properties for the GlobalContextMenu component | Deprecated |
GlobalDialogProps | Properties for the GlobalDialog component | Deprecated |
GlobalDialogState | State properties for the GlobalDialog component | Deprecated |
IconInputProps | Properties for the IconInput component | Deprecated |
IconProps | Properties for the Icon React component | Deprecated |
ImageCheckBoxProps | Properties for the ImageCheckBox component | Deprecated |
InputLabelProps | Properties for InputLabel components | Deprecated |
LabeledComponentProps | Properties for labeled components | Deprecated |
ListboxContextProps | Listbox Context. |
Deprecated |
ListboxItemProps | ListboxItem Props. |
Deprecated |
ListboxProps | Listbox Props. |
Deprecated |
LoadingBarProps | Properties for LoadingBar component | Deprecated |
LoadingPromptProps | Properties for LoadingPrompt component | Deprecated |
LoadingSpinnerProps | Properties for LoadingSpinner component | Deprecated |
LoadingStatusProps | Properties for LoadingStatus component | Deprecated |
MainTabsProps | Properties for the base Tabs component | Deprecated |
Properties for the MessageBox component | Deprecated | |
Properties for the MessageContainer component | Deprecated | |
Properties for components with messages | Deprecated | |
Properties for the MessageRenderer component | Deprecated | |
NoChildrenProps | Props used by components that do not expect children to be passed in. | Deprecated |
NodeCheckboxProps | Properties for Tree Node CheckBox | Deprecated |
NumberInputProps | Properties for the NumberInput component | Deprecated |
PopupContextMenuProps | Properties for PopupContextMenu component | Deprecated |
PopupProps | Properties for the Popup component | Deprecated |
ProcessSettingsContainerCloseEventArgs | Arguments of this.onProcessSettingsContainerClose event. | Deprecated |
ProcessSettingsTabActivationEventArgs | Arguments of this.onProcessSettingsTabActivation event. | Deprecated |
RadialButtonProps | Properties for RadialButton component | Deprecated |
RadialMenuProps | Properties for RadialMenu | Deprecated |
RatioChangeResult | Results returned by onRatioChanged callback for determining new ratio and whether the ratio was updated. | Deprecated |
Describes a React based message | Deprecated | |
RectangleProps | Describes 2d bounds. | Deprecated |
RenderPropsArgs | Prop the ElementResizeObserver sends to the render function. | Deprecated |
SearchBoxProps | Properties for SearchBox component | Deprecated |
SettingsContainerProps | Properties of SettingsContainer component. | Deprecated |
SettingsProvidersChangedEventArgs | Arguments of this.onSettingsProvidersChanged event. | Deprecated |
SettingsTabEntry | Interface used to populate a tab entry in the SettingContainer control | Deprecated |
SettingsTabsProvider | Setting Provider interface. | Deprecated |
SizeProps | Describes 2d dimensions. | Deprecated |
StyledTextProps | Properties for StyledText component | Deprecated |
SvgPathProps | Properties of SvgPath component. | Deprecated |
TabLabel | TabLabel provides ability to define label, icon, and tooltip for a tab entry. | Deprecated |
TabsProps | Properties for the VerticalTabs component | Deprecated |
TextProps | Properties for various text components | Deprecated |
TreeBranchProps | Properties for TreeBranch React component | Deprecated |
TreeNodePlaceholderProps | Properties for the TreeNodePlaceholder React component | Deprecated |
TreeNodeProps | Properties for the TreeNode React component | Deprecated |
TreeProps | Properties for the Tree presentational React component | Deprecated |
UiStateStorage | Interface for getting, saving and deleting settings. | Deprecated |
UiStateStorageResult | Interface for result of accessing UI state setting in UiStateStorage. | Deprecated |
UnderlinedButtonProps | Properties for the UnderlinedButton React component | Deprecated |
WebFontIconProps | Properties for the WebFontIcon React component | Deprecated |
WithIsPressedProps | Properties for withIsPressed React higher-order component | Deprecated |
WithOnOutsideClickProps | Properties for withOnOutsideClick React higher-order component | Deprecated |
WithTimeoutProps | Properties for withTimeout React higher-order component | Deprecated |
Type Aliases
Name | Description | |
---|---|---|
AsyncGetAutoSuggestDataFunc | Prototype for async function returning AutoSuggestData | Deprecated |
BadgeType | Specifies type of badge, if any, that should be overlaid on UI component. | Deprecated |
ExecuteHandler | Signature for Timer execute callback. | Deprecated |
GetAutoSuggestDataFunc | Prototype for function returning AutoSuggestData | Deprecated |
IconSpec | Prototype for an IconSpec which can be a string, ReactNode or ConditionalStringValue. | Deprecated |
ListboxValue | Listbox value. |
Deprecated |
Types for message | Deprecated | |
NodeCheckboxRenderer | Type for node Checkbox renderer | Deprecated |
NodeCheckboxRenderProps | Props for node Checkbox renderer | Deprecated |
Omit | Used to omit properties in a given interface | |
OmitChildrenProp | Omit children property from T. | |
OutsideClickEvent | Deprecated | |
RadialSizeType | Type for ProgressRadialProps.size | Deprecated |
StepFunctionProp | Step function prototype for NumberInput component | Deprecated |
Last Updated: 07 August, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.