Dialog
Classes for working with a dialog
Classes
Name | Description | |
---|---|---|
ContentDialogRenderer | ContentDialogRenderer React component renders modeless dialogs. | |
DialogChangedEvent | Dialog Changed Event class. | Deprecated |
ModalDialogChangedEvent | Modal Dialog Changed Event class. | Deprecated |
ModalDialogRenderer | ModalDialogRenderer React component renders modal dialogs | |
ModelessDialog | Modeless Dialog React component uses the Dialog component with a modal={false} prop. | Deprecated |
ModelessDialogChangedEvent | Modeless Dialog Changed Event class. | Deprecated |
ModelessDialogRenderer | ModelessDialogRenderer React component renders modeless dialogs. |
Global Functions
Name | Description | |
---|---|---|
ContentDialog | Content Dialog React component uses the Dialog component with a modal={false} prop. | Deprecated |
StandardMessageBox React component displays a standard icon, message text and a standard button set in the lower right. | Deprecated | |
UiDataProvidedDialog | Component to show dialog populated from properties supplied via uiDataProvider | Deprecated |
Interfaces
Name | Description | |
---|---|---|
ContentDialogProps | Properties for the ContentDialog component | Deprecated |
DialogChangedEventArgs | Dialog Stack Changed Event Args class. | Deprecated |
DialogInfo | Information maintained by a Dialog Manager about a dialog | |
FrameworkDialog | Manages dialog access | |
FrameworkDialogs | dialogs interface. | |
FrameworkStackedDialog | FrameworkDialog that manages the top most content. | |
ModelessDialogInfo | ||
ModelessDialogProps | Properties for the ModelessDialog component | Deprecated |
Properties for StandardMessageBox React component | Deprecated | |
UiDataProvidedDialogProps | Props for UiDataProvidedDialog component. | Deprecated |
Last Updated: 28 June, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.