LocatingElements
Classes for locating and snapping to elements in views. See the learning articles.
Classes
Name | Description | |
---|---|---|
AccuSnap | AccuSnap is an aide for snapping to interesting points on elements or decorations as the cursor moves over them. | |
ElementLocateManager | ||
ElementPicker | ||
HitDetail | A HitDetail stores the result when locating geometry displayed in a view. | |
HitList | The result of a "locate" is a sorted list of objects that satisfied the search criteria (a HitList). | |
IntersectDetail | ||
LocateOptions | Options that customize the way element location (i.e. | |
LocateResponse | ||
SnapDetail | A SnapDetail is generated from the result of a snap request. | |
TentativeOrAccuSnap | TentativeOrAccuSnap returns information about an active snap generated by either AccuSnap or TentativePoint. | |
TentativePoint |
Enumerations
Name | Description | |
---|---|---|
HitDetailType | ||
HitGeomType | What was being tested to generate this hit. | |
HitParentGeomType | Classification of GeometricPrimitive that generated the Hit. | |
HitPriority | ||
HitSource | The procedure that generated this Hit. | |
LocateAction | The possible actions for which a locate filter can be called. | |
LocateFilterStatus | Values to return from a locate filter. | |
SnapHeat | ||
SnapMode | ||
SnapStatus |
Interfaces
Name | Description | |
---|---|---|
HitDetailProps | Arguments supplied to the HitDetail constructor. | |
HitListHolder | ||
HitPath | As part of a HitDetail, describes a series of "attached" views through which the hit was located. | |
SectionDrawingAttachmentHitInfo | As part of a HitPath, describes the SectionDrawing, if any, from which the hit represented by a HitDetail originated. | |
ViewAttachmentHitInfo | As part of a HitPath, describes the ViewAttachment, if any, from which the hit represented by a HitDetail originated. |
Namespaces
Name | Description | |
---|---|---|
AccuSnap |
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.