TentativePoint Class
Methods
Name | Description | |
---|---|---|
constructor(): TentativePoint | ||
clear(doErase: boolean): void | ||
decorate(context: DecorateContext): void | ||
getCurrSnap(): undefined | SnapDetail | ||
getHitAndList(holder: HitListHolder): undefined | SnapDetail | ||
getPoint(): Point3d | ||
onButtonEvent(ev: BeButtonEvent): void | ||
onInitialized(): void | ||
process(ev: BeButtonEvent): void | ||
removeTentative(): void | ||
setCurrSnap(newSnap?: SnapDetail): void | ||
setHitList(list?: HitList<HitDetail>): void | ||
setPoint(point: Point3d): void | ||
showTentative(): void |
Properties
Name | Type | Description | |
---|---|---|---|
currSnap | SnapDetail | undefined | ||
isActive | boolean | ||
isSnapped Accessor ReadOnly | boolean | ||
tpHits | HitList<HitDetail> | undefined | ||
viewport | ScreenViewport | undefined |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.