Tiles
Classes representing graphics as hierarchical 3d tiles.
Classes
Name | Description | |
---|---|---|
BingElevationProvider | Provides an interface to the Bing Maps elevation services. | |
BingLocationProvider | Provides an interface to the Bing Maps location services. | |
DisclosedTileTreeSet | A set of TileTrees disclosed by a set of objects implementing TileTreeDiscloser, used to collect references to tile trees in use by those objects. | |
EllipsoidTerrainProvider | A terrain mesh provider that produces geometry that represents a smooth ellipsoid without any height perturbations. | |
GeographicTilingScheme | A MapTilingScheme using a simple geographic projection by which longitude and latitude are mapped directly to X and Y. | |
ImageryMapLayerTreeReference | A reference to one of our tile trees. | |
MapCartoRectangle | A specialization of Range2d representing a Cartographic region on the surface of the Earth, | |
MapLayerTileTreeReference | A TileTreeReference to be used specifically for MapTileTrees. | |
MapTile | A Tile belonging to a MapTileTree representing a rectangular region of a map of the Earth. | |
MapTileProjection | Projects points within the rectangular region of a MapTile into 3d space. | |
MapTileTree | A quad tree consisting of MapTiles representing the map imagery draped onto the surface of the Earth. | |
MapTilingScheme | A scheme for converting between two representations of the surface of the Earth: an ellipsoid and a rectangular tiled map. | |
QuadId | Identifies a node within a quad tree, such as a MapTile within a MapTileTree. | |
RealityTile | A Tile within a RealityTileTree, representing part of a reality model (e.g., a point cloud or photogrammetry mesh) or 3d terrain with map imagery. | |
RealityTileTree | Base class for a TileTree representing a reality model (e.g., a point cloud or photogrammetry mesh) or 3d terrain with map imagery. | |
TerrainMeshProvider | Provides 3d meshes representing terrain for display in a Viewport. | |
TerrainProviderRegistry | A registry of TerrainProviders identified by their unique names. | |
Tile | A 3d tile within a TileTree. | |
TileAdmin | Manages Tiles and TileTrees on behalf of IModelApp. | |
TileDrawArgs | Provides context used when selecting and drawing Tiles. | |
TileGeometryCollector | Collects geoemtry from a GeometryTileTreeReference within a specified volume at a specified level of detail. | |
TileRequest | Represents a pending or active request to load the contents of a Tile. | |
TileRequestChannel | A channel over which requests for tile content can be made. | |
TileRequestChannels | A set of named TileRequestChannels via which content for Tiles can be requested. | |
TileRequestChannelStatistics | Statistics regarding the current and cumulative state of one or more TileRequestChannels. | |
TileTree | A hierarchical level-of-detail tree of 3d Tiles to be rendered in a Viewport. | |
TileTreeReference | A reference to a TileTree suitable for drawing within a Viewport. | |
TileUsageMarker | A marker associated with a Tile to track usage of that tile by any number of TileUsers. | |
WebMercatorTilingScheme | A MapTilingScheme using the EPSG:3857 projection. |
Enumerations
Name | Description | |
---|---|---|
MapTileTreeScaleRangeVisibility | Map tile tree scale range visibility values. | |
TileBoundingBoxes | Options for displaying tile bounding boxes for debugging purposes. | |
TileGraphicType | Describes the type of graphics produced by a TileTreeReference. | |
TileLoadPriority | Loosely describes the "importance" of a Tile. | |
TileLoadStatus | Describes the current status of a Tile's content. | |
TileTreeLoadStatus | Describes the current state of a TileTree. | |
TileVisibility | Describes the visibility of a tile based on its size and a view frustum. |
Global Functions
Name | Description | |
---|---|---|
getCesiumAssetUrl | Return the URL for a Cesium ION asset from its asset ID and request Key. | |
readElementGraphics | Convert the byte array returned by requestElementGraphics into a RenderGraphic. | |
readGltf | Produce a RenderGraphic from a glTF asset suitable for use in view decorations. | |
readGltfGraphics | Produce a RenderGraphic from a glTF asset suitable for use in view decorations. | |
readGltfTemplate | Produce a GraphicTemplate from a glTF asset suitable for use in view decorations. |
Interfaces
Name | Description | |
---|---|---|
BatchTableProperties | Provides access to per-feature properties within a RealityTileTree. | |
GeometryTileTreeReference | A TileTreeReference that can supply geometry in the form of Polyfaces from Tiles belonging to its TileTree and satisfying the criteria defined | |
GltfGraphic | The output of readGltf. | |
GltfTemplate | The output of readGltfTemplate. | |
GpuMemoryLimits | Defines separate GpuMemoryLimits for mobile and desktop clients. | |
MapLayerIndex | Position of a map-layer in the display style's map (i.e. | |
ReadGltfGraphicsArgs | Arguments supplied to readGltfGraphics to produce a RenderGraphic from a glTF asset. | |
ReadMeshArgs | Arguments supplied to readMesh. | |
RealityDataSource | This interface provide methods used to access a reality data from a reality data provider | |
RealityTileGeometry | The geometry representing the contents of a reality tile. | |
RenderGraphicTileTreeArgs | Arguments supplied to createFromRenderGraphic. | |
RequestMeshDataArgs | Arguments supplied to requestMeshData. | |
TerrainMeshProviderOptions | Options supplied to createTerrainMeshProvider to construct a TerrainMeshProvider. | |
TerrainProvider | Interface adopted by an object that can supply TerrainMeshProviders enabling the display of 3d terrain in a Viewport. | |
TileContent | Describes the contents of a Tile. | |
TileContentDecodingStatistics | As part of a TileRequestChannelStatistics, summarizes cumulative time spent decoding tile content. | |
TileDrawArgParams | Parameters used to construct TileDrawArgs. | |
TileGeometryCollectorOptions | Options for creating a TileGeometryCollector. | |
TileParams | Parameters used to construct a Tile. | |
TileTreeDiscloser | Interface adopted by an object that contains references to TileTrees, to expose those trees. | |
TileTreeOwner | Owns and manages the lifecycle of a TileTree. | |
TileTreeParams | Parameters used to construct a TileTree. | |
TileTreeSupplier | Interface adopted by an object which can supply a TileTree for rendering. | |
TileUser | Represents some object that makes use of Tiles in some way - e.g., by requesting and/or displaying their contents, querying their geometry, etc. |
Namespaces
Name | Description | |
---|---|---|
RealityDataSource | Utility functions for RealityDataSource | |
TileAdmin | ||
TileRequest | ||
TileUser |
Type Aliases
Name | Description | |
---|---|---|
CollectTileStatus | Enumerates the statuses returned by collectTile. | |
GpuMemoryLimit | Describes a strategy for imposing limits upon the amount of GPU memory consumed by Tile content. |
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.