TileGeometryCollector Class
Collects geoemtry from a GeometryTileTreeReference within a specified volume at a specified level of detail. Subclasses can refine the collection criterion. The tile geometry is obtained asynchronously, so successive collections over multiple frames may be required before all of the geometry is collected.
Methods
Name | Description | |
---|---|---|
constructor(options: TileGeometryCollectorOptions): TileGeometryCollector | Create a new collector. | |
addMissingTile(tile: Tile): void | Allows an implementation of collectTileGeometry to indicate that the specified tile's content must be loaded | |
collectTile(tile: Tile): CollectTileStatus | Determine whether to collect the specified tile's geometry, reject it, or to evaluate the geometry of its child tiles for collection. | |
markLoading(): void | Allows an implementation of collectTileGeoemtry to indicate that further loading is required before | |
requestMissingTiles(): void | Enqueues requests to obtain the content of any tiles whose content is required to complete the geometry collection. |
Properties
Name | Type | Description | |
---|---|---|---|
_options Protected Readonly | TileGeometryCollectorOptions | The options used to construct this collector. | |
isAllGeometryLoaded Accessor ReadOnly | boolean | Returns true if polyfaces has been fully populated with all the geometry satisfying this collector's criteria. | |
polyfaces Readonly | IndexedPolyface[] | The list of accumulated polyfaces, populated during collectTileGeometry. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.