Item
Classes for working with an Item in a Tool Widget, Navigation Widget or Backstage
Classes
Name |
Description |
|
ActionButtonItemDef |
Abstract base class that is used by classes to execute an action when pressed. |
Deprecated |
CommandItemDef |
An Item that executes a Command. |
Deprecated |
CustomItemDef |
An Item that renders a React component. |
Deprecated |
GroupItemDef |
An Item that opens a group of items. |
Deprecated |
ItemDefBase |
The base class for Items. |
Deprecated |
ItemList |
Contains a list of Items. |
Deprecated |
ItemMap |
Contains a map of Items. |
Deprecated |
ToolInformation |
Provides information about a tool with a given id, including the ToolUiProvider. |
Deprecated |
ToolItemDef |
An Item that starts the execution of a Tool. |
Deprecated |
Constants
Enumerations
Interfaces
Name |
Description |
|
BaseItemState |
Base state for any 'stateful' React component. |
Deprecated |
CommandHandler |
Definition for a command handler. |
Deprecated |
CommandItemProps |
Properties for a Command item. |
Deprecated |
ConditionalValue |
Interface used to track the conditional value of a generic type T . |
|
Properties for context menu items. |
|
CustomItemProps |
Definition for a Custom item that renders a React component. |
Deprecated |
GroupItemProps |
Definition for a Group item that opens a group of items. |
Deprecated |
ItemProps |
Definition that specifies properties shared between many ConfigurableUi components. |
Deprecated |
ToolItemProps |
Properties for a Tool item with a tool id. |
Deprecated |
Type Aliases
Last Updated: 06 November, 2024